Konqueror: ottimizzazioni varie

Konqueror
Konqueror

Adesso che sono passato a KDE 4 (ieri l’ho aggiornato alla 4.1.67), ho deciso di passare da firefox a konqueror.
Tuttavia, almeno inizialmente, mi sono sentito abbastanza “a disagio”: connessione lenta, pagine che non si caricavano, plugin flash che non funzionava…

Andiamo quindi con ordine:

Connessione Lenta
Googlando un po’ ho scoperto che il problema principale era l’IPv6, quindi se non si possiede un router IPv6 e non si vuole fare del tunnelling IPv6->IPv4, bisogna disabilitare questa funzionalità.
Per farlo bisogna innanzitutto verificare che nel kernel il supporto all’IPv6 sia caricato come modulo (o non caricato), quindi bisogna impedire il caricamento dei relativi moduli (in particolare il modulo ipv6), per far questo è possibile inserire nella blacklist dei moduli (in gentoo si trova nel file /etc/modprobe.d/blacklist) la voce:

blacklist ipv6

NOTA: vi sono anche altri metodi per disabilitare l’IPv6, ma nel mio caso sono falliti tutti…

Inoltre vi conviene controllare i vostri server DNS, e nel caso passare a quelli di OpenDNS, basta editare il file /etc/resolv.conf, inserendo le voci:

nameserver xxx.yyy.zzz.www

Pagine che non si caricavano
Per risolvere (anche se non totalmente) questo problema ho installato polipo, che permette di utilizzare meccanismi di pipelining (richieste in parallelo) anche con browser (come konqueror) che non li supportano nativamente.

Plugin Flash
Per risolvere questo problema ho seguito questa ottima guida

Ora la navigazione è più che accettabile, inoltre finalmente ho un browser davvero integrato con il resto del sistema!!!

KDE 4.1++: ci sono (+ o -)!

È stata dura ma finalmente ho finito di installare e configurare KDE 4 (versione 4.1.66)!

Durante questo processo mi accaduto di tutto: lo slot 4.1 dell’overlay di gentoo “kdesvn-portage” è sparito giusto 24h dopo il termine della mia installazione, quindi mi sono ritrovato a doverla eliminare e passare allo slot 4.2, lo slot 3.5 mi bloccava a caso alcuni pacchetti del 4.2, quindi ho deciso di eliminare completamente kde 3.5.9, a questo punto OpenOffice.org si è sentito offeso perchè voleva le kdelibs-3.5.9, quindi ho dovuto reinstallare OpenOffice (ovviamente da sorgenti!!).

Infine quando pensavo di aver sistemato tutto ho scoperto che Phonon 4.1.66 non permetteva l’utilizzo di xine (ma solo di Gstreamer), e per qualche motivo non si decideva a suonare, quindi sono passato a Phonon SVN…

Ora spero di aver terminato tutto o quasi (per ora l’ambiente è in inglese, perchè il pacchetto kde-l10n è presente solo su SVN e richiede di passare allo slot SVN, lo stesso discorso vale per kwallet).
[Update]
Adesso kwallet è presente e funzionante

Però finalmente il sistema è usabile!!!

KDE 4.1 ++
KDE 4.1 ++

Internet a 64 bit: finalmente un successo!

Qualche tempo fa avevo provato a passare in modo stabile ad una versione a 64 bit di firefox, tuttavia dopo un po’ di tempo sono stato costretto a tornare sui miei passi a causa di svariati problemi (leggasi Java e Flash).

http://www.flickr.com/photos/zoolcar9/
http://www.flickr.com/photos/zoolcar9/

Adesso con l’avvento di Firefox 3 ho deciso di riprovarci, ed ecco i risultati:

_Java: ancora niente da fare, ma ultimamente trovo sempre meno siti con applet Java, quindi non lo considero un grave problema

_Flash: con nspluginwrapper funziona a meraviglia, non so se è merito di firefox, di nspluginwrapper o di flash (credo che siano uscite nuove versioni di tutti e tre, quindi non so quale abbia corretto i bug di cui soffrivo l’ultima volta)

Quindi ho deciso di passare stabilmente a firefox a 64 bit… almeno fino ai prossimi problemi!